1. Welcome to LilyPad. Download the project, explore the forums, and create your own LilyPad network.

    If you use the software and enjoy it or have a question, or would like to contribute to the future of the software directly or through resources, please sign up and join our little community.

Invalid Big Error and not connecting after reloading

Discussion in 'Bug Reports' started by Superfuzzy, Sep 3, 2014.

  1. Superfuzzy

    Superfuzzy Member

    Explanation of Bug: When reloading the server (latest craftbukkit or spigot), LilyPad-Connect will crash with an error when it gets enabled and will not even try to reconnect. When you stop and start the server, everything runs normal.

    The Bug:
    Code (text):
    [13:41:15] [Server thread/INFO]: [LilyPad-Connect] Enabling LilyPad-Connect v83
    [13:41:15] [Server thread/WARN]: javassist.NotFoundException: net.minecraft.server.v1_7_R4.PacketHandshakingInSetProtocol$stringMaxSize65535
    [13:41:15] [Server thread/WARN]:    at javassist.ClassPool.get(ClassPool.java:450)
    [13:41:15] [Server thread/WARN]:    at javassist.ClassPool.getCtClass(ClassPool.java:515)
    [13:41:15] [Server thread/WARN]:    at lilypad.bukkit.connect.injector.PacketInjector.injectStringMaxSize(PacketInjector.java:35)
    [13:41:15] [Server thread/WARN]:    at lilypad.bukkit.connect.ConnectPlugin.onEnable(ConnectPlugin.java:49)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:412)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugin(CraftServer.java:476)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.enablePlugins(CraftServer.java:394)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.reload(CraftServer.java:865)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.Bukkit.reload(Bukkit.java:301)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:23)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:181)
    [13:41:15] [Server thread/WARN]:    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.dispatchCommand(CraftServer.java:767)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.PlayerConnection.handleCommand(PlayerConnection.java:1043)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.PlayerConnection.a(PlayerConnection.java:880)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.PacketPlayInChat.a(PacketPlayInChat.java:28)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.PacketPlayInChat.handle(PacketPlayInChat.java:65)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.NetworkManager.a(NetworkManager.java:186)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.ServerConnection.c(ServerConnection.java:81)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.MinecraftServer.v(MinecraftServer.java:734)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.DedicatedServer.v(DedicatedServer.java:289)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.MinecraftServer.u(MinecraftServer.java:584)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:490)
    [13:41:15] [Server thread/WARN]:    at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628)
    [13:41:15] [Server thread/INFO]: [Connect] Unable to start plugin - unsupported version?

    Version: Using latest Proxy (#105,Windows/Linux), Connect (#44,Windows/Linux), Bukkit-Connect (#83) and craftbukkit (#3116) /spigot (#1646).

    Reproduction of Bug: Reloading the server, you won't even have to join the server.

    I hope this will get fixed soon. I run a Windows 7 OS, a friend of mine who had the same error runs Linux.

    Have a nice day ;)
    @Coelho & Team keep up the good work
  2. The_Zip

    The_Zip Active Member Resource Contributor

    I am running this on both Mac OSX, and Linux CentOS. Both run smoothly and I do not get this occurrence.

    If someone else who runs windows could test it out, we might be able to shed some more light on it.

    Another thought too @Coelho , I am running the latest version of the Bukkit-Connect, however it logs version 77.

    Code (text):
    [06:44:00 INFO]: [LilyPad-Connect] Loading LilyPad-Connect v77
  3. Coelho

    Coelho Software Engineer Staff Member Administrator Maintainer

    Seems fine for me.

    LilyPad-Connect is no longer reload safe. If you want to reload individual plugins, please use a plugin like "PlugMan" instead of the /reload command.
  4. Superfuzzy

    Superfuzzy Member

    Do you plan on fixing it @Coelho or will it stay like this, because that'll suck.. (and maybe even make new lilypad users jump back to bungeecord if this stays permanent..):(
  5. Coelho

    Coelho Software Engineer Staff Member Administrator Maintainer

    You should never use the /reload command anyway. It's an awful habit and an extremely broken command.
  6. The_Zip

    The_Zip Active Member Resource Contributor

    Weird, the plugin.yml version I was running was version 77. Downloaded it again, 83...

Share This Page