1. Welcome to LilyPad. Download the project, explore the forums, and create your own LilyPad network.

    If you use the software and enjoy it or have a question, or would like to contribute to the future of the software directly or through resources, please sign up and join our little community.

Solved Tried basic install on VPS. Can't connect with minecraft.

Discussion in 'Support' started by Ramt 1, Jul 22, 2014.

  1. Ramt 1

    Ramt 1 New Member

    Go-Server-Connect: 32
    Go-Server-Proxy: 79
    VPS Host: ExodusServers
    Linux: Centos-6-x86-64
    Minecraft: 1.7.2
    Spigot: spigot-1.7.2-R0.3-SNAPSHOT

    I want to connect three servers running Cauldron to a spigot lobby server. I followed the instructions here on setting up GoLilyPad. Proxy authenticated with connect and like in the video at the bottom of the instructions, I started minecraft to see if I could reach my lilypad server and I can't.
    I tried connecting to port 25565 and 5091 but no luck. Then I realized I might need to open the ports which I did using
    iptables -A INPUT -p tcp --dport 25565 -j ACCEPT

    iptables -A INPUT -p tcp --dport 6881 -j ACCEPT

    But minecraft still can't reach the server.
  2. TakeMeNL

    TakeMeNL Member Resource Contributor

    Do you mind to show your Connect en Proxy configs? (Mark out passwords and sush)
  3. The_Zip

    The_Zip Active Member Resource Contributor

    And, when you try to connect to the minecraft servers are you getting a requested server is not online message? Or some java error?
  4. Ramt 1

    Ramt 1 New Member

    bind: :5091
    - username: LilyServer
    password: LilyServerPassword
    - regexp: LobbyServer
    password: LobbyServerPassword

    username: LilyServer
    password: LilyServerPassword
    bind: :25565
    - domain: ""
    server: :LobbyServer
    full: The server seems to be currently full. Try again later!
    offline: The requested server is currently offline. Try again later!
    loggedIn: You seem to be logged in already. Try again later!
    lostConn: Lost connection... Please try to reconnect
    shutdown: The server is being restarted. Please try to reconnect
    motd: A LilyPad Server
    maxPlayers: 50
    authenticate: true
    Last edited: Jul 22, 2014
  5. Ramt 1

    Ramt 1 New Member

    It just says "Can't connect to server" after pinging for awhile. And if I click on it anyway there's a ReadTimeoutException.
  6. The_Zip

    The_Zip Active Member Resource Contributor

    Ok, well it's not a problem with LilyPad. Your configs are set up correctly, other than in your connect servers config where you are using regexp, if you do not understand what it is I would just change it to username. To double check that LP is set up, make sure in all of your screens that you see the message that it is connected.

    Now for your firewall, I am assuming you are using http://exodusservers.com/ from a quick google search, you need to make sure 25565 is open and 5091(I'm not sure about 5091 as you are running everything of the same server using local host). A good tutorial for that is can be found here http://www.minecraftforum.net/forum...tutorial-dedicated-minecraft-the-correct-way/ . If you are still having the issue, check with your host, make sure they are not blocking 25565 and ask what type of ddos protection they are using, you issue could be there.
  7. Ramt 1

    Ramt 1 New Member

    Thank you.

    I would think that 5091 would have to be open because this VPS just runs LilyPad, not the MC servers. My minecraft servers are also hosted by exodus, but on their Multicraft setup.
  8. The_Zip

    The_Zip Active Member Resource Contributor

    Your correct, you forgot to mention that part. Your Minecraft servers will be connecting to the connect server, therefor the port that it is running on must be open.

    Let us know how it goes!
  9. Ramt 1

    Ramt 1 New Member

    I figured out one problem, that my iptables weren't being saved because the command didn't exist. But I fixed it from what I read here. I added the correct ports and opened all output just like in that tutorial you linked, but minecraft isn't getting anything when I connect to the default port.

    Here is my iptables --list

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT tcp -- anywhere anywhere tcp dpt:25565
    ACCEPT tcp -- anywhere anywhere tcp dpt:5091
    ACCEPT icmp -- anywhere anywhere icmp echo-request

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere

    Just to clear something, if I set up lilypad, but don't connect a MC server to lilypad, minecraft will still be able to reach the lilypad network at "lilypadIP":25565 ? Because that's what the video led me to believe.
  10. Ramt 1

    Ramt 1 New Member

    Every few minutes or so on my proxy screen this happens:
    Connect client, disconnected: EOF
    Connect client, authenticated to remote host

    And on the connect screen:
    Connect server, authorized: LilyServer.592ae82440eee81f80d2eb301e042737 ip:
    Connect server, roled as proxy: LilyServer ip:
    Connect server, id: LilyServer ip: disconnected: use of closed network connection

    Is it normal for it to be disconnecting and reconnecting so often?
  11. Ramt 1

    Ramt 1 New Member

    I tried to connect my hub server to LilyPad, I got the same connection refused message as when I connect via client.

    I talked to staff at Exodus, but they said they don't block traffic from their minecraft nodes, which is where my MC servers are hosted. He also said "I whitelisted your VPS IP address on the firewall on the server that your hub shared server is running on, so if it's still not able to connect it would be an issue with your configuration." After which, my connection was still refused. Even with iptables completely disabled on the LilyPad VPS, no luck.
  12. The_Zip

    The_Zip Active Member Resource Contributor

    Ok, so I am a little confused in this situation now. You mentioned that you disabled the iptables, did you also disable your firewall? If you have your firewall disabled, and there is not some external ip for your ddos protection, just turning on your LP proxy server will show it online. If you are getting this error when your try to join your server(picture below), than your issue is still with your firewall/iptables. For proof of this, you can either try to run a plain minecraft server on the port, or even something your hosting company could understand like a web server.

  13. Ramt 1

    Ramt 1 New Member

    The Exodus staff I spoke with understand Minecraft very well. He tried to convince me to use BungeeCord, but I went down that road last weekend. Turns out, it's incompatible with Forge, and I'm running Pixelmon servers. Which is why I moved on to LilyPad.

    Pardon my Linux ignorance, but what is there in terms of firewall besides iptables? I will try a vanilla MC server and see if that works.

    This is the connection error I'm currently getting:
  14. Ramt 1

    Ramt 1 New Member

    Sometimes, when I stop connect-linux-amd64 I get this error: (I'm not sure if it's relevant though.)

    panic: runtime error: close of closed channel

    goroutine 1 [running]:
    runtime.panic(0x596fa0, 0x7b4a35)
    /var/lib/jenkins/.go/src/pkg/runtime/panic.c:266 +0xb6
    /var/lib/jenkins/jobs/Go-Server-Connect/builds/2014-02-28_19-34-43/golang/go/src/github.com/LilyPad/GoLilyPad/server/connect/server.go:51 +0x53
    /var/lib/jenkins/jobs/Go-Server-Connect/builds/2014-02-28_19-34-43/golang/go/src/github.com/LilyPad/GoLilyPad/server/connect/main/main.go:47 +0x44
    /var/lib/jenkins/jobs/Go-Server-Connect/builds/2014-02-28_19-34-43/golang/go/src/github.com/LilyPad/GoLilyPad/server/connect/main/main.go:73 +0xd2e

    goroutine 3 [syscall]:
    syscall.Syscall(0x0, 0x0, 0xc210066000, 0x1000, 0x5, ...)
    /var/lib/jenkins/.go/src/pkg/syscall/asm_linux_amd64.s:18 +0x5
    syscall.read(0x0, 0xc210066000, 0x1000, 0x1000, 0x5, ...)
    /var/lib/jenkins/.go/src/pkg/syscall/zsyscall_linux_amd64.go:838 +0x72
    syscall.Read(0x0, 0xc210066000, 0x1000, 0x1000, 0x5, ...)
    /var/lib/jenkins/.go/src/pkg/syscall/syscall_unix.go:135 +0x5c
    os.(*File).read(0xc210000000, 0xc210066000, 0x1000, 0x1000, 0x5, ...)
    /var/lib/jenkins/.go/src/pkg/os/file_unix.go:180 +0x62
    os.(*File).Read(0xc210000000, 0xc210066000, 0x1000, 0x1000, 0x41ff39, ...)
    /var/lib/jenkins/.go/src/pkg/os/file.go:95 +0x98
    /var/lib/jenkins/.go/src/pkg/bufio/bufio.go:91 +0x110
    bufio.(*Reader).ReadSlice(0xc2100576c0, 0x41380a, 0x0, 0x0, 0x0, ...)
    /var/lib/jenkins/.go/src/pkg/bufio/bufio.go:274 +0x204
    bufio.(*Reader).ReadBytes(0xc2100576c0, 0x54d80a, 0x0, 0x0, 0x0, ...)
    /var/lib/jenkins/.go/src/pkg/bufio/bufio.go:355 +0xbf
    bufio.(*Reader).ReadString(0xc2100576c0, 0xc21005b10a, 0x0, 0x0, 0x0, ...)
    /var/lib/jenkins/.go/src/pkg/bufio/bufio.go:395 +0x55
    /var/lib/jenkins/jobs/Go-Server-Connect/builds/2014-02-28_19-34-43/golang/go/src/github.com/LilyPad/GoLilyPad/server/connect/main/main.go:31 +0x72
    created by main.main
    /var/lib/jenkins/jobs/Go-Server-Connect/builds/2014-02-28_19-34-43/golang/go/src/github.com/LilyPad/GoLilyPad/server/connect/main/main.go:37 +0x291
  15. Ramt 1

    Ramt 1 New Member

    I set up a default MC server. It started just fine. [INFO] Starting Minecraft server on *:25565 But I still could not connect. It also couldn't bind to port if I set the server-ip= to my VPS IP in the server.properties.

    I'm going to go ask my host about their DDoS protection.
  16. Ramt 1

    Ramt 1 New Member

    Ok...I figured out the problem. Somehow, the IP I had for SSH was different than the one that Minecraft or anything else would connect to. This is probably because I got the IP form their online console SSH thing.

    Anyway, I was able to connect my lobby server to LilyPad. And connect to it with Minecraft. But I've encountered a new issue.

    If more than one person connects, the world won't load for the second person and then both players get a ReadTimeoutException.
  17. Tzeentchful

    Tzeentchful Member Contributor

    Are you using the most updated version of the proxy and bukkit connect?
  18. Ramt 1

    Ramt 1 New Member

    Sorry, we figured it out. It was a problem with spigot.

    Doesn't matter too much. Turns out LilyPad can't connect Cauldron servers, so it's useless to me.

Share This Page